LEARNING MADE EASY

3rd Edition

Excel Macros

for d

ummies

A Wiley Bran

Be G Vew imet Do Fomst Wwow Hep

Jaemen et segasion e
et et pgery setenent
e g

¥ focsare e agadirt dhve
9 Juttve otnotgysrsa
s sy i

¥ 0P80 ks
b
2 o
e
L
[oriceit
3 i ey
eyt

rsa
L

k Kusleika






ummies

A Wiley Brand






[ ~ "~ Y

060

Excel
Macros

3rd Edition

by Dick Kusleika

dummies
A Wiley Brand



Excel® Macros For Dummies®, 3rd Edition

Published by: John Wiley & Sons, Inc., 111 River Street, Hoboken, NJ 07030-5774, www.wiley.com
Copyright © 2022 by John Wiley & Sons, Inc., Hoboken, New Jersey

Published simultaneously in Canada

No part of this publication may be reproduced, stored in a retrieval system or transmitted in any form or by any
means, electronic, mechanical, photocopying, recording, scanning or otherwise, except as permitted under Sections
107 or 108 of the 1976 United States Copyright Act, without the prior written permission of the Publisher. Requests to
the Publisher for permission should be addressed to the Permissions Department, John Wiley & Sons, Inc., 111 River
Street, Hoboken, NJ 07030, (201) 748-6011, fax (201) 748-6008, or online at http://www.wiley.com/go/permissions.

Trademarks: Wiley, For Dummies, the Dummies Man logo, Dummies.com, Making Everything Easier, and related
trade dress are trademarks or registered trademarks of John Wiley & Sons, Inc. and may not be used without written
permission. Microsoft and Excel are registered trademarks of Microsoft Corporation. All other trademarks are the
property of their respective owners. John Wiley & Sons, Inc. is not associated with any product or vendor mentioned
in this book.

LIMIT OF LIABILITY/DISCLAIMER OF WARRANTY: WHILE THE PUBLISHER AND AUTHORS HAVE USED THEIR
BEST EFFORTS IN PREPARING THIS WORK, THEY MAKE NO REPRESENTATIONS OR WARRANTIES WITH RESPECT
TO THE ACCURACY OR COMPLETENESS OF THE CONTENTS OF THIS WORK AND SPECIFICALLY DISCLAIM ALL
WARRANTIES, INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. NO WARRANTY MAY BE CREATED OR EXTENDED BY SALES
REPRESENTATIVES, WRITTEN SALES MATERIALS OR PROMOTIONAL STATEMENTS FOR THIS WORK. THE FACT
THAT AN ORGANIZATION, WEBSITE, OR PRODUCT IS REFERRED TO IN THIS WORK AS A CITATION AND/OR
POTENTIAL SOURCE OF FURTHER INFORMATION DOES NOT MEAN THAT THE PUBLISHER AND AUTHORS
ENDORSE THE INFORMATION OR SERVICES THE ORGANIZATION, WEBSITE, OR PRODUCT MAY PROVIDE OR
RECOMMENDATIONS IT MAY MAKE. THIS WORK IS SOLD WITH THE UNDERSTANDING THAT THE PUBLISHER IS
NOT ENGAGED IN RENDERING PROFESSIONAL SERVICES. THE ADVICE AND STRATEGIES CONTAINED HEREIN
MAY NOT BE SUITABLE FOR YOUR SITUATION. YOU SHOULD CONSULT WITH A SPECIALIST WHERE APPROPRIATE.
FURTHER, READERS SHOULD BE AWARE THAT WEBSITES LISTED IN THIS WORK MAY HAVE CHANGED OR
DISAPPEARED BETWEEN WHEN THIS WORK WAS WRITTEN AND WHEN IT IS READ. NEITHER THE PUBLISHER
NOR AUTHORS SHALL BE LIABLE FOR ANY LOSS OF PROFIT OR ANY OTHER COMMERCIAL DAMAGES, INCLUDING
BUT NOT LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL, OR OTHER DAMAGES.

For general information on our other products and services, please contact our Customer Care Department within
the U.S. at 877-762-2974, outside the U.S. at 317-572-3993, or fax 317-572-4002. For technical support, please visit
https://hub.wiley.com/community/support/dummies.

Wiley publishes in a variety of print and electronic formats and by print-on-demand. Some material included with
standard print versions of this book may not be included in e-books or in print-on-demand. If this book refers to
media such as a CD or DVD that is not included in the version you purchased, you may download this material at
http://booksupport.wiley.com. For more information about Wiley products, visit www.wiley.com.

Library of Congress Control Number: 2022931276

ISBN: 978-1-119-84443-3 (pbk); ISBN: 978-1-119-84444-0 (ePDF); ISBN: 978-1-119-84445-7 (ePub)


http://www.wiley.com
http://www.wiley.com/go/permissions
https://hub.wiley.com/community/support/dummies
http://booksupport.wiley.com
http://www.wiley.com

Contents at a Glance

Introduction..................... 1
Part 1: Holy MacroBatman! ..................................... 7
cHAPTER 1: Macro Fundamentals. ... 9
cHAPTER 22 Getting Cozy with the Visual BasicEditor................... ... .. 29
cHAPTER 3: The Anatomy of Macros. ...... ..o et 43
Part 2: Making Short Work of Workbook Tasks ............. 57
cHApPTER 4: Working with Workbooks ....... ... .. o i i i 59
cHapTErR 5: Working with Worksheets.......... ... oo i i i 81
Part 3: One-Touch Data Manipulation....................... 107
cHAPTER6: Feelingat HomeontheRange. ..., 109
cHAPTER 7: Manipulating Datawith Macros. ......... ..o, 129
Part 4: Macro-Charging Reports and Emails ................ 163
cHAPTER 8: Automating Common Reporting Tasks. . .........ccoviiiio... 165
cHApTER 9: Sending Emails from Excel ... 199
cHAPTER 10: Wrangling External Data withMacros. . ..., 217
Part5:PartofTens ...l 235
cHAPTER 11: Ten Handy Visual Basic Editor Tips . ..., 237
cHAPTER 12: Ten Places to Turn for MacroHelp ........ ... o it 247
CHAPTER 13: Ten Ways to Speed Up YOUr Macros. . ...ovvivnee e 253






Table of Contents

INTRODUCTION ... e 1
ABOUt ThISBOOK. ... 2

Foolish ASSumptions. . ...t i e 3

lcons Used iNnThiSBOOK .. ....ovvun i e 3

Beyond the BoOK. ... .ot 3
Whereto GofromHere ... 4

PART 1: HOLY MACRO BATMAN! ... 7
cuaerer: Macro Fundamentals............................. 9
Choosingto Use aMacro. ...ttt 9

Macro Recording Basics . .. .ovvveiin e 10
Examiningthe macro ....... ..o 12
Editingthemacro .......... .o 13
Testingthemacro ... ..ottt e 14

Comparing Absolute and Relative Macro Recording ............... 14
Recording macros with absolute references. .................. 14

Recording macros with relative references.................... 17
Understanding Macro Security . .......oviinne i 19
Macro-enabled file extensions ......... ... ... i 20

Trusted dOCUMENES. .. ..o o ittt 20

Trusted locations. ...ttt 20

Storingand RUNNINg MAacros . .. ..o vei it i 21

Storing macros in your Personal Macro Workbook . ............ 22

Assigning a macro to a button and other form controls......... 22

Placing a macro on the Quick Access Toolbar. ................. 24

Exploring Macro Examples. ... ..o 25

Building navigation buttons. . .......... ... i 25

Dynamically rearranging PivotTabledata ..................... 26

Offering one-touch reporting options ........................ 27

caerer 2. Getting Cozy with the Visual Basic Editor ........... 29
Working in the Visual Basic Editor. . ........... ..., 29
TheVBEmenubar. ... 30

The VBEtoolbars. ... 31

The Project EXplorer .. ..ot 31

The Code Pane. ...ttt e 31

The Immediate window ......... .ot 31

Working with the Project Explorer ..., 32
AddinganewVBAmodule............. .. i 32
RemovingaVBAmModule ... 34

Table of Contents vii



viii

WorkingwithaCodePane. ... ... it 34

Minimizing and maximizingwindows. . ....................... 34
Getting VBA codeintoamodule........... ... .o i, 35
Customizingthe VBE. .. ... .. 38
TheEditortab. ... i 38
The Editor Formattab.......... .. ... 40
The Generaltab...........oo i 41
TheDockingtab. ..ot e e 42
chapTer: The Anatomy of Macros................................ 43
A Brief Overview of the Excel Object Model ...................... 43
Understanding objects .. ...t 44
Understanding collections .. ... ... 45
Understanding properties .........ooiiiiinniiiin i 45
Understanding methods ......... ... oo, 46
A Brief Look atVariables .......... ... .o i 46
The common variabletypes. ... 47
Understanding Event Procedures. .........covviiiviiniinennnnn. 49
Worksheetevents . ... ..ot 49
Workbook events. . ... .. 51
Error Handlingina Nutshell ....... ... .. o i it 52
On Error GoTo Somelabel. ... ..., 53
OnErrorResume Next ...t 54
ONError GOTO 0. .o v vt e 55
PART 2: MAKING SHORT WORK OF
WORKBOOK TASKS. ... 57
cuarrer 2. Working with Workbooks.............................. 59
INStalling Macros . . ..ottt e e e 60
EVeNt Macros . ....oo vt e 60
Personal Macro Workbook. . .......... ... o it 60
Standard MacroS. ...t 61
Creating a New Workbook from Scratch......................... 61
Saving a Workbook when a Particular Cell Is Changed ............. 63
Saving a Workbook before Closing. ..., 65
Protecting a Worksheet on Workbook Close. ..................... 67
Unprotecting a Worksheet. . ...... ... ... o i i, 68
Opening a Workbook to a SpecificTab .................. ... ... .. 69
Opening a Specific Workbook Defined by the User................ 70
Determining Whether a Workbook Is Already Open . .............. 72
Determining Whether a Workbook Exists in a Directory............ 74
Closing All Workbooks atOnce . ...t 76
Printing All Workbooks ina Directory. ... ... 77
Preventing the Workbook from Closing Until a Cell Is Populated . ...78
Creating a Backup of the Current Workbook with Today's Date ... . .. 80

Excel Macros For Dummies



CHAPTER 5:

Working with Worksheets ............................. 81

INStalling MacroS . ..o et e 81
EVeNntmacros ... 82
Personal Macro Workbook. ........... ..o 82
Standard MacroS. . ..o vvvi e 83

Adding and Naming a New Worksheet .......................... 83

Deleting All but the Active Worksheet ................ .. ... .. 84

Hiding All but the Active Worksheet............ ... . oot 86

Unhiding All Worksheets in a Workbook .. .................... ... 87

Moving Worksheets Around ........ ..ot 88

Sorting Worksheetsby Name ......... ... ... i, 90

Grouping Worksheetsby Color. ..., 92

Copying a Worksheet to a New Workbook ....................... 94

Creating a New Workbook for Each Worksheet . .................. 94

Printing Specified Worksheets. .. ... i 96

Protecting All Worksheets ...... ..., 97

Unprotecting All Worksheets. ...... ... i, 98

Creating a Table of Contents for Your Worksheets ............... 100

Zooming In and Out of a Worksheet with Double-Click............ 103

Highlighting the Active Rowand Column........................ 104

PART 3: ONE-TOUCH DATA MANIPULATION .............. 107
cerere: Feeling at HomeontheRange ....................... 109

INStalling Macros . .. oo oo 110
Eventmacros ... i 110
Personal Macro Workbook. .......... ... ...t 110
Standard MacroS. . ...t 111

Selecting and FormattingaRange ........... ... .o, 111

Creating and Selecting Named Ranges ......................... 113

Looping Througha RangeofCells ........ ... ..ot 116

Inserting Blank RowsinaRange............... ..o, 117

Unhiding AllRows and Columns. . .......ooviiiineinneenn.. 119

Deleting Blank ROWS . . ..ottt 119

Deleting Blank Columns . ... ..ot e 121

Limiting Range Movement to a ParticularArea .................. 122

Selecting and Formatting All Formulas in a Workbook ............ 123

Finding and Selecting the First Blank Row or Column............. 126

caerer 72 Manipulating Data with Macros ..................... 129

INStalling Macros . .. oo o 130
Eventmacros ... 130
Personal Macro Workbook. .......... ... ...t 131
Standard Macros. ... 131

Table of Contents ix



X

Copyingand PastingaRange ............. oo, 131

Converting All FormulasinaRangetoValues.................... 132
Text to Columnson AllColumns. ... 134
Converting Trailing Minus Signs ..., 137
Trimming Spaces from All CellsinaRange...................... 139
Truncating Zip Codes to the LeftFive........... ... ... o0 141
Padding Cellswith Zeros .......c.ov i, 143
Replacing Blanks CellswithaValue ............ ... .. ... .. 145
Appending Text to the Left or Right of Your Cells................. 147
Cleaning Up Non-Printing Characters ............ccoivvvunn... 149
Highlighting Duplicatesina RangeofData...................... 151
Hiding All but Rows Containing DuplicateData .................. 152
Selectively Hiding AutoFilter Drop-down Arrows ................. 155
Copying Filtered Rows to a New Workbook ..................... 157
Showing Filtered Columns inthe StatusBar..................... 158

PART 4: MACRO-CHARGING REPORTS AND EMAILS...... 163

CHAPTER 8:

CHAPTER 9:

Automating Common Reporting Tasks............. 165
INStalling Macros . . ..ot e e 166

EVeNt Macros . ....oo i 166

Personal Macro Workbook. . .......... . ... o i 166

Standard MacroS. .. ..ot 167
Refreshing All PivotTables in a Workbook....................... 167
Creating a List of PivotTables. . ........ ... .coiiiiiiiinn s, 169
Adjusting All Pivot Data Field Titles. . ........ ... ... 172
Setting All Data ltemstoSum ...ttt 173
Applying Number Formatting for All Data ltems ................. 175
Sorting All Fields in Alphabetical Order ......................... 178
Applying a Custom Sortto Dataltems................ . ... ... 179
Applying PivotTable Restrictions. ........ ...t 180
Applying Pivot Field Restrictions......... ...t 182
Automatically Deleting PivotTable Drill-Down Sheets ............. 184
Printing a PivotTable for Each Report Filterltem . ................ 187
Creating a New Workbook for Each Report Filter Item ............ 189
Resizing All Charts on a Worksheet ......... ... ... ... ... 192
Aligning a Chartto a SpecificRange . ...t 193
Creating a Set of Disconnected Charts. .................coovun. 195
Printing All Charts on a Worksheet......................ooua. 196
Sending Emails fromExcel ............................ 199
INStalling Macros . . ..ot e e e 200

EVeNt macros . ...t 200

Personal Macro Workbook. . .......... ... o i 200

Standard MacroS. .. ..ot 201

Excel Macros For Dummies



Mailing the Active Workbook as an Attachment.................. 201

Mailing a Specific Range as an Attachment...................... 203

Mailing a Single Sheet as an Attachment........................ 205

Sending Mail with a Link to Your Workbook ..................... 207

Mailing All Email Addresses in Your ContactList ................. 209

Saving All AttachmentstoaFolder........... ... .. ... .. ..., 211

Saving Certain AttachmentstoaFolder......................... 213
cuaerer 10: Wrangling External Data with Macros.............. 217
Working with External Data Connections ....................... 217
Manually creating a connection ............. ..ot 218

Manually editing data connections. . ........................ 221

Using Macros to Create Dynamic Connections. .................. 222

Iterating through All Connections in a Workbook ................ 224

Using ADO and VBA to Pull ExternalData....................... 226
Understanding ADO SyntaX .. .....vvvetinneniinn e, 226

USING ADO IN@MaCrO. .« ottt et ie e et ee e aenns 228

Working with Text Files. . ... i i 231
Openingatextfile..... ..ot 231

Reading the opened textfile .......... ... .. it 232

A practical example: Logging workbook usage in a textfile. . ... 232

A practical example: Importing a textfiletoarange........... 233

PART 5: THEPARTOFTENS.................... i, 235
cuarrer 11: T€N Handy Visual Basic Editor Tips .................. 237
Applying Block Comments. . ...t 238

Copying Multiple Lines of CodeatOnce ..., 239

Jumping between Modules and Procedures..................... 240
Teleporting to Your Functions. ..., 240
Stayingin the Right Procedure ........ ... ... ... 241

Stepping through Your Code....... ..o, 241

Stepping to a Specific LineinYourCode .............. ...t 242

Stopping Your Code at a Predefined Point ...................... 243

Seeing the Beginning and End of Variable Values ................ 244

Turning Off Auto Syntax Check . ... 245
cuarrer 12 T€N Places to Turn for MacroHelp .................. 247
Let Excel Write the MacroforYou. .............ooviiiiiinnn.. 248
UsetheVBAHelpFiles ...... ..o i 248

Pilfer Code fromthelInternet............ ..., 248

Leverage User FOrUMS ... .ottt et 249

Visit EXpert BIogs. . .o oo 250

Mine YouTube for Video Training . . ..., 251

Table of Contents xi



xii

Attend Live and Online Training Classes
Learn from the Microsoft Office DevCenter.....................
Dissect the Other Excel Files in your Organization
Ask Your Local Excel Genius

cuarter 13: T€N Ways to Speed Up Your Macros
Halt Calculations ...... ...
Disable ScreenUpdating . ......ccoiiiiiiniiii i
Turn Off Status Bar Updates
Tell Exceltolgnore Events . ...
Hide Page Breaks. . ... ..ot
Suspend PivotTable Updates. ...,
Steer Clear of Copy and Paste
Usethe With Statement........ ...
Don't Explicitly Select Objects . ......c.ovviiiii i
Avoid Excessive Trips to the Worksheet

Excel Macros For Dummies



Introduction

n its broadest sense, a macro is a sequence of instructions that automates some

aspect of Excel so that you can work more efficiently and with fewer errors. You

might create a macro, for example, to format and print a month-end sales
report. After you develop the macro, you can execute it to perform many time-
consuming procedures automatically.

Macros are written in VBA, which stands for Visual Basic for Applications. VBA is
a programming language developed by Microsoft and a tool used to develop pro-
grams that control Excel.

Excel programming terminology can be a bit confusing. For example, VBA is a
programming language but also serves as a macro language. What do you call
something written in VBA and executed in Excel? Is it a macro or is it a program?
Excel’s Help system often refers to VBA procedures as macros, so this is the termi-
nology used in this book.

You also see the term automate throughout this book. This word means that a
series of steps are completed automatically. For example, if you write a macro that
adds color to some cells, prints the worksheet, and then removes the color, you
have automated those three steps.

You’re probably aware that people use Excel for thousands of different tasks. Here
are just a few examples:

¥ Keeping lists of things, such as customer names and transactions
¥ Budgeting and forecasting

¥ Analyzing scientific data

¥ Creating invoices and other forms

3 Developing charts from data
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The list could go on and on. The point is simply that Excel is used for a wide vari-
ety of tasks, and everyone reading this book has different needs and expectations
regarding Excel. One thing most readers have in common, however, is the need to
automate some aspect of Excel, which is what macros (and this book) are all about.

About This Book

2

This book approaches the topic of Excel macros with the recognition that pro-
gramming VBA takes time and practice — time that you may not have right now.
In fact, many analysts don’t have the luxury of taking a few weeks to become
expert at VBA. So instead of the same general overview of VBA topics, this book
provides some of the most commonly used real-world Excel macros.

Each section in the book outlines a common problem and provides an Excel macro
to solve the problem — along with a detailed explanation of how the macro works
and where to use it.

Each section presents the following:

3 The problem
¥ The macro solution

3 How the macro works
After reading each section, you’ll be able to

¥ Immediately implement the required Excel macro
¥ Understand how the macro works

¥ Reuse the macro in other workbooks or with other macros

The macros in this book are designed to get you up and running with VBA in the
quickest way possible. Each macro tackles a common task that benefits from
automation. The idea here is to learn through application. This book is designed
so that you can implement the macro while getting a clear understanding of what
the macro does and how it works.

Excel Macros For Dummies



Foolish Assumptions

I make three assumptions about you as the reader:

¥ You've installed Microsoft Excel.

¥ You have some familiarity with the basic concepts of data analysis, such as
working with tables, aggregating data, creating formulas, referencing cells,
filtering, and sorting.

3 You have an Internet connection so you can download the sample files.

Icons Used in This Book

Tip icons cover tricks or techniques related to the current discussion.

TIP

@ Remember icons indicate notes or asides that are important to keep in mind.

REMEMBER

Warning icons hold critical information about pitfalls you will want to avoid.

WARNING

— The icons marks particuarly geeky parts of Excel and VBA. If you’re into the tech-
\ nical aspects, read on. If you’re not, you can completely skip paragraphs marked

tecunica  With this paragraph and still get your macros to work.

STUFF

Beyond the Book

In addition to the material in the print or e-book you’re reading, this product
comes with more online goodies:

¥ Sampile files: Each macro in this book has an associated sample file that
enables you to see the macro working and to review the code. You can use
the sample files also to copy and paste the code into your environment (as
opposed to typing each macro from scratch). Download the sample files at:

Introduction 3



REMEMBER

Q

www . dummies.com/go/excelmacrosfd3e

Each macro in this book has detailed instructions on where to copy and paste
the code. In general terms, you open the sample file associated with the
macro, open the Visual Basic Editor (by pressing Alt+F11), and copy the code.
Then open your workbook, open the Visual Basic Editor, and paste the code in
the appropriate location.

Note that in some macros, you need to change the macro to suit your
situation. For example, in the macro that prints all workbooks in a directory
(see Chapter 4), you point to the C:\Temp\ directory. Before using this macro,
you must edit it to point to your target directory.

If a macro is not working for you, most likely a component of the macro needs
to be changed. Pay special attention to range addresses, directory names, and
any other hard-coded names.

¥ Cheat sheet: The cheat sheet offers shortcut keys that can help you work
more efficiently in Excel's Visual Basic Editor. You can find the cheat sheet by
visiting www . dummies . com and searching for “Excel Macros Cheat Sheet.”

Where to Go from Here

4

If you’re completely new to Excel macros, start with Part 1 (Chapters 1-3) to get
the fundamentals you need to understand the macros in this book. There, you gain
a concise understanding of how macros and VBA work, along with the basic foun-
dation you need to implement the macros provided in this book.

If you’ve got some macro experience and want to dive right into the macro exam-
ples, feel free to peruse Chapters 4—9 and search for the task or macro that looks
interesting to you. Don’t worry. Each macro example stands on its own within its
own section that gives you all the guidance you need to understand and imple-
ment the code in your own workbook.

Visit Part 2 if you’re interested in macros that automate common workbook and
worksheet tasks to save time and gain efficiencies.

Explore Part 3 to find macros that navigate ranges, format cells, and manipulate
the data in your workbooks.

Excel Macros For Dummies
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If you want to find macros that work with PivotTables, charts, and emails, thumb
through the macros in Part 4 where you discover macros that automate redundant
PivotTable and chart tasks, as well as macros that send emails and connect to
external data sources.

Don’t forget to hit Part 5 for some useful tips and advice on how to get the most
out of your new macro skills.

Here are some final things to keep in mind while working with the macros in this
book:

»

»

»

»

Any file that contains a macro must have the .xIsm file extension. See
the section on macro-enabled file extensions in Chapter 1 for more
information.

Excel does not run macros until they are enabled. As you implement these
macros, you and your customers must comply with Excel's macro security
measures. See the section in Chapter 1 on macro security in Excel for details.

You cannot undo macro actions. When working in Excel, you can often undo
the actions you've taken because Excel keeps a log (called the undo stack)
recording your last 100 actions. However, running a macro automatically
destroys the undo stack, so you can’t undo the actions you take in a macro.

You need to tweak the macros to fit your workbook. Many of the macros
reference example sheet names and ranges that you may not have in your
workbook. Be sure to replace references such as “Sheet 1” or Range (“A1") with
the sheet names and cell addresses you are working with in your own
workbooks.

Introduction
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IN THIS PART ...

Build a foundation for your macro skills with
fundamental macro recording concepts.

Get a solid understanding of the ground rules for
using and distributing macros in Excel.

Explore Excel's coding environment with a deep-dive
of the Visual Basic Editor.

Explore how to leverage the Excel object model to
start writing your own macros from scratch.

Understand the roles played by variables, events, and
error handling in macro development.



IN THIS CHAPTER

» Choosing macros

» Recording macros
» Understanding macro security

» Finding out where to store and how
to run macros

» Exploring macro examples

Chapter 1
Macro Fundamentals

macro is essentially a set of instructions or code that you create to tell Excel
to execute any number of actions. In Excel, macros can be written or
recorded. The key word here is recorded.

Recording a macro is like programming a phone number into your smartphone.
You first manually dial and save a number. Then when you want, you can redial
those numbers with the touch of a button. With macro recording, you can record
your actions in Excel while you perform them. While you record, Excel gets busy
in the background, translating your keystrokes and mouse clicks to code (also
known as Visual Basic for Applications or VBA). After a macro is recorded, you can
play back those actions anytime you want.

In this chapter, you explore macros and find out how you can use macros to auto-
mate your recurring processes to simplify your life.

Choosing to Use a Macro

The first step in using macros is admitting you have a problem. Actually, you may
have several problems:

3 Problem 1— repetitive tasks: As each new month rolls around, you have to
make the donuts (that is, crank out those reports). You have to import that

CHAPTER 1 Macro Fundamentals 9



»

»

data. You have to update those PivotTables. You have to delete those
columns, and so on. With a macro you could have those more redundant
parts of your monthly process processes done automatically.

Problem 2 — you're making mistakes: When you go hand-to-hand combat
with Excel, you're bound to make mistakes. When you're repeatedly applying
formulas, sorting, and moving things around manually, there’s always that risk
of catastrophe. Add to that the looming deadlines and constant change
requests, and your error rate goes up. Or you could calmly record a macro,
ensure that everything is running correctly, and then forget it. The macro
performs every action the same way every time you run it, reducing the
chance of errors.

Problem 3 — awkward navigation: You often create reports for an audience
that probably has a limited knowledge of Excel. It's always helpful to make
your reports more user-friendly. Macros can be used to dynamically format
and print worksheets, navigate to specific sheets in your workbook, or even
save the open document in a specified location. Your audience will appreciate
these little touches that help make perusal of your workbooks a bit more
pleasant.

Macro Recording Basics

10

To start recording your first macro, you need to first find the Macro Recorder,
which is on the Developer tab. Unfortunately, Excel comes out of the box with the
Developer tab hidden — you may not see it on your version of Excel at first. If you
plan to work with VBA macros, you’ll want to make sure that the Developer tab is
visible. To display this tab

1.
2.
3.
4.

Choose File > Options.
In the Excel Options dialog box, click Customize Ribbon.
In the list box on the right, place a check mark next to Developer.

Click OK to return to Excel.

Now that you have the Developer tab showing in the Excel Ribbon, you can start
up the Macro Recorder by selecting Record Macro from the Developer tab. This
activates the Record Macro dialog box, as shown in Figure 1-1.

PART 1 Holy Macro Batman!



FIGURE 1-1:
The Record
Macro dialog box.

REMEMBER

Record Macro ? X

Macro name:
Macro1

Shortcut key:

Store macro in:
This Workbook b

Description:

Ctrl+

Cancel

Here are the four parts of the Record Macro dialog box:

»

»

»

»

Macro Name: Excel gives a default name to your macro, such as Macro1, but
you should give your macro a name more descriptive of what it actually does.
For example, you might name a macro that formats a generic table as
FormatTable.

You have to follow a few rules when naming a macro. The first character must

be a letter. Generally, special characters other than underscore aren't allowed.

And the total number of characters can't be more than 255, although hope-
fully you don't get close to that limit.

Shortcut Key: Every macro needs an event, or something to happen, for it to
run. This event can be a button press, a workbook opening, or if you use this
field, a keystroke combination. When you assign a shortcut key to your macro,
entering that combination of keys triggers your macro to run. This is an
optional field.

Store Macro In: This Workbook is the default option. Storing your macro in
This Workbook simply means that the macro is stored along with the active
Excel file. The next time you open that particular workbook, the macro is
available to run. Similarly, if you send the workbook to another user, that user
can run the macro as well (provided the macro security is properly set by your
user — more on that later in this chapter). You can also choose New
Workbook to tell Excel to create a new workbook to store the macro or
Personal Macro Workbook, a special workbook used to store macros you
want access to all the time. See “Storing and Running Macros” later in this
chapter for more on the Personal Macro Workbook.

Description: This field is optional, but it can come in handy if you have
numerous macros in a workbook or if you need to give a user a more detailed
description about what the macro does.

CHAPTER 1 Macro Fundamentals
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With the Record Macro dialog box open, follow these steps to create a simple
macro that enters your name into a worksheet cell:

1. Enteranew single-word name for the macro to replace the default
Macro1 name.
A good name for this example is MyName.
2. Assign this macro to the shortcut key Ctri+Shift+N.
You do this by entering uppercase N in the edit box labeled Shortcut Key.
3. Cclick OK.
This closes the Record Macro dialog box and begins recording your actions.

4. select cell B3 on your worksheet, type your name into the selected cell,
and then press Enter.

5. choose Developer~> Coder~> Stop Recording (or click the Stop Recording
button in the status bar).

Examining the macro

The macro was recorded in a new module named Module1. To view the code in this
module, you must activate the Visual Basic Editor. (See Chapter 2 to find out more
about the Visual Basic Editor.) You can activate the VB Editor in one of three ways:

¥ Press Alt+F11.
¥ Choose Developer > Code = Visual Basic.

3 Choose Developer > Code = Macros, select a macro, and click Edit.

In the VB Editor, the Project window displays a list of all open workbooks and add-
ins. If the Project Explorer isn’t visible, choose View=> Project Explorer. This list is
displayed as a tree diagram, which you can expand or collapse. The code that you
recorded previously is stored in Module1 in the current workbook. When you
double-click Module1, the code in the module appears in the Code window.

The macro should look something like this:

Sub MyName ()

1

' MyName Macro

1

' Keyboard Shortcut: Ctrl4Shift+N

1
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Range("B3").Select
ActiveCell .FormulaR1C1 = "Dick Kusleika"
Range("B4").Select

End Sub

The macro recorded is a Sub procedure named MyName. The statements tell Excel
what to do when the macro is executed.

Notice that Excel inserted some comments at the top of the procedure. These
comments are some of the information that appeared in the Record Macro dialog
box. These comment lines (which begin with an apostrophe) aren’t really neces-
sary, and deleting them has no effect on how the macro runs. If you ignore the
comments, you'll see that this procedure has three VBA statements, the second of
which is:

ActiveCell .FormulaR1C1 = "Dick Kusleika"

The first statement is selecting cell B3. The last statement is pressing Enter after
you enter your name, which moves the active cell down one row. The middle
statement, the one that does all the work, causes the name you typed while
recording to be inserted into the active cell.

Editing the macro

After you record a macro, you can make changes to it. The macro you recorded in
the previous section always inserts your name into cell B3. Edit the macro so that
it enters your name in whatever cell you happen to be in when you run it. To do
that, delete the first and third lines of the macro. The edited macro appears as
follows:

Sub MyName ()
' MyName Macro

' Keyboard Shortcut: Ctrl+Shift+N

ActiveCell .FormulaR1C1 = "Dick Kusleika"
End Sub

This macro inserts text into the active cell because the first Select statement was

removed. That same cell remains active because the second Select statement was
removed.
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Testing the macro

Before you recorded this macro, you set an option that assigned the macro to the
Ctrl+Shift+N shortcut key combination. To test the macro, return to Excel by using
either of the following methods:

¥ Press Alt+F11.

9 Click the View Microsoft Excel button on the VB Editor toolbar.

When Excel is active, activate a worksheet. (It can be in the workbook that con-
tains the VBA module or in any other workbook.) Select a cell and press
Ctrl+Shift+N. The macro immediately enters your name into the cell.

Comparing Absolute and Relative
Macro Recording

14

TIP

Excel has two modes for recording — absolute reference and relative reference.
These modes affect what statements Excel generates when you select cell while
recording. In this section, I discuss the two modes and when to use them.

Recording macros with absolute references

In the example in the preceding section, you selected cell B3 while recording a
macro and Excel dutifully recorded a statement that selects cell B3. This is an
example of an absolute reference and it’s the default mode when recording mac-
ros. The term absolute reference is often used in the context of cell references
found in formulas. When a cell reference in a formula is an absolute reference, it
does not automatically adjust when the formula is pasted to a new location.

The best way to understand how this concept applies to macros is to try it. Open
the Chapter 1 Sample File.xlsx file and record a macro that counts the rows in the
Branchlist worksheet. (See Figure 1-2.)

The sample dataset used in this chapter can be found on the book’s companion
website.
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FIGURE 1-2:
Your pre-totaled
worksheet
containing two
tables.

mM22 &7 Je
A B C D E F G H | J

1 Region Market Branch Region Market Branch
2 NORTH BUFFALO 601413 SOUTH CHARLOTTE 173501
3 NORTH BUFFALO 701407 SOUTH CHARLOTTE 301301
4 NORTH BUFFALO 802202 S0OUTH CHARLOTTE 302301
5 NORTH CANADA 910131 S0OUTH CHARLOTTE 601306
6 NORTH CANADA 920681 SOUTH DALLAS 202600
7 NORTH MICHIGAN 101413 SOUTH DALLAS 430260
8 NORTH MICHIGAN 501405 SOUTH DALLAS 430360
9 NORTH MICHIGAN 503405 SOUTH DALLAS 430460
10 NORTH MICHIGAN 590140 SOUTH FLORIDA 301316
11 NORTH NEWYORK 801211 SOUTH FLORIDA 701309
12 NORTH NEWYORK 802211 SOUTH FLORIDA 702309
13 NORTH NEWYORK 804211 SOUTH NEWORLEANS 601310
14 NORTH NEWYORK 805211 SOUTH NEWORLEANS 602310
1= NORTH NEWYORK 806211 SOUTH NEWORLEANS 801607
16

Follow these steps to record the macro:

. Before recording, make sure cell A1 is selected.

Select Record Macro from the Developer tab.

Name the macro AddTotal.

Choose This Workbook for the save location.

VA WN=

. Click OK to start recording.

At this point, Excel is recording your actions. While Excel is recording, perform
the following steps:

1. Select cell A16 and type Total in the cell.
2. Select the first empty cell in Column D (D16) and enter = COUNTA(D2:D15).

This gives a count of branch numbers at the bottom of column D. You need
to use the COUNTA function because the branch numbers are
stored as text.

6. click Stop Recording on the Developer tab to stop recording the macro.

The formatted worksheet should look something like the one in Figure 1-3.

To see your macro in action, delete the total row you just added and play back your
macro by following these steps:

1. click Macros on the Developer tab.

2. Find and select the AddTotal macro you just recorded.

3. Click the Run button.
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If all goes well, the macro plays back your actions to a T and gives your table a
total. Now here’s the thing: No matter how hard you try, you can’t make the
AddTotal macro work on the second table (G1:115 in Figure 1-3). Why? Because you
recorded the macro using absolute references.

To understand what this means, examine the underlying code. To examine the
code, click Macros on the Developer tab to open the Macro dialog box, as shown in

Figure 1-4.
A B C D E F <] H | J
1 Region Market Branch Region Market Branch
2 MNORTH BUFFALO 601419 SOUTH CHARLOTTE 173901
3 NORTH BUFFALO 701407 SOUTH CHARLOTTE 301301
4 NORTH BUFFALO 802202 SOUTH CHARLOTTE 302301
5 MNORTH CANADA 910181 SOUTH CHARLOTTE 601306
6 NORTH CANADA 920681 SOUTH DALLAS 202600
T NORTH MICHIGAN 101419 SOUTH DALLAS 490260
8 MNORTH MICHIGAN 501405 SOUTH DALLAS 490360
g NORTH MICHIGAN 503405 SOUTH DALLAS 450460
10 NORTH MICHIGAN 5390140 SOUTH FLORIDA 301316
1 NORTH NEWYORK 801211 SOUTH FLORIDA 701309
12 NORTH NEWYORK 802211 SOUTH FLORIDA 702309
13 NORTH NEWYORK 804211 SOUTH NEWORLEANS 601310
14 NORTH NEWYORK 805211 SOUTH NEWORLEANS 602310
FIGURE 1-3: 15 NORTH NEWYORK 806211 SOUTH NEWORLEANS 801607
Your post-totaled 16 |Total 14
worksheet. 17

Macro 7 X
Macro name:
AddTotal 3
AddTotal
Step Into
Edit
Create
Delete
Options...
Macros in: | This Workbook ~
Description
FIGURE 1-4:
The Excel Macro Cancel
dialog box.
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