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INTRODUCTION

Excel is a very popular program. Millions of people throughout the world use it on a regular basis. But 

it’s a safe bet that the vast majority of users have yet to discover some of the amazing things this 

product can do. If I’ve done my job, you’ll find enough useful information in this book to help you use 

Excel on a new level.

What You Should Know
This book isn’t a beginner’s guide to Excel. Rather, it’s a book for those who already use Excel but 

realize that they have a lot more to learn. This book contains 101 tips and tricks that I’ve learned over 

the years, and I’m certain that about 99 percent of all Excel users will find something new and useful 

in these pages.

If you have absolutely no experience with Excel, this book might not be the best choice for you. To get 

the most out of this book, you should have some background in using Excel. Specifically, I assume that 

you know how to accomplish the following tasks with Excel:

➤ Create workbooks, insert worksheets, save files, and perform other basic tasks.

➤ Navigate through a workbook.

➤ Use the Excel Ribbon and dialog boxes.

➤ Use basic Windows features, such as file management and copy-and-paste techniques.

What You Should Have
To use this book, you need a copy of Microsoft Excel 2013 for Windows. If you use an older version of 

Excel, some of the tips won’t apply.

As far as hardware goes for the computer you use to run Excel, the faster, the better. And, of course, 

the more memory in your system, the happier you’ll be.
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Conventions in This Book
Take a minute to skim this section and become familiar with some of the typographic conventions 

used throughout this book.

Formula listings
Formulas usually appear on a separate line in monospace font. For example, I might list the following 

formula:

=VLOOKUP(StockNumber,PriceList,2,False)

Excel supports a special type of formula known as an array formula. When you enter an array formula, 

press Ctrl+Shift+Enter (not just Enter). Excel encloses an array formula in curly braces to remind you 

that it’s an array formula.

Note  

Don’t type the curly braces for an array formula. Excel puts them in automatically.

Key names
Names of keys on the keyboard appear in normal type: for example, Alt, Home, PgDn, and Ctrl. When 

you need to press two or more keys simultaneously, the keys are connected with a plus sign: Press 

Ctrl+G to display the Go To dialog box.

The Ribbon
Excel 2013 features the Ribbon user interface, which was introduced in Excel 2007.

When you need to select a command by using the Ribbon, I describe the command by using the tab 

name, the group name, and the command name: for example, Choose Home➜Alignment➜Wrap 

Text. This command translates to “Click the Home tab, locate the Alignment group, and then click the 

Wrap Text button.”

Some commands use a drop-down Ribbon control. For example: Home➜Styles➜Conditional 

Formatting➜New Rule. In this case, you need to click the down-pointing arrow on the Conditional 

Formatting control in order to access the New Rule command.

Many commands begin with the word File. Clicking the File tab takes you to the Backstage View.
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Functions, procedures, and named ranges
The names of the Excel worksheet functions appear in all uppercase letters: for example, “Use the 

SUM function to add the values in column A.”

Unless you’re dealing with text inside quotation marks, Excel isn’t sensitive to case. In other words, 

both the following formulas produce the same result:

=SUM(A1:A50)
=sum(a1:a50)

Excel, however, converts the characters in the second formula to uppercase.

Mouse conventions
The mouse terminology in this book is all standard fare: pointing, clicking, right-clicking, dragging, 

and so on. You know the drill.

What the icons mean
Throughout this book, icons appear in the left margin to call your attention to points that are particu-

larly important.

Note  

I use Note icons to tell you that something is important — perhaps a concept that can 

help you master the task at hand or something fundamental for understanding subse-

quent material.

Caution 

I use Caution icons when the operation I’m describing can cause problems if you’re not 

careful.

Cross-Ref 

I use the Cross-Reference icon to refer you to other tips that have more to say on a par-

ticular topic.
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How This Book Is Organized
To provide some semblance of order, I grouped these tips and tricks into six parts:

➤ Part I: Workbooks and Files

➤ Part II: Formatting

➤ Part III: Formulas

➤ Part IV: Working with Data

➤ Part V: Tables and Pivot Tables

➤ Part VI: Charts and Graphics

How to Use This Book
This book really isn’t intended to be read from cover to cover, as you would read a novel — but I’m 

sure that some people will do so. More likely, you’ll want to use it as a reference book and consult it 

when necessary. If you’re faced with a challenging task, you may want to check the index first to see 

whether the book specifically addresses your problem. The order of the parts and tips is arbitrary. 

Most readers will probably skip around and pick up useful tidbits here and there.

There are also an additional 30 bonus tips that you’ll find at www.dummies.com/go/101excel
2013tips.

About the Power Utility Pak Offer
Toward the back of this book is a coupon that you can redeem for a discounted copy of my award-

winning Power Utility Pak — a collection of useful Excel utilities, plus many new worksheet functions.

You can also use this coupon to purchase the complete VBA source code for a nominal fee. Study-

ing the code is an excellent way to pick up some useful programming techniques. You can 

take the product for a test drive by downloading the trial version from my website at http:
//spreadsheetpage.com.

Note  

Power Utility Pak version 7 requires the Windows version of Excel 2007 or later.

http://www.dummies.com/go/101excel


PART I
Workbooks 
and Files
In this part, you’ll find tips and tricks covering some of the basics of Excel, including 
Protected View and AutoRecover, as well as working with the Quick Access toolbar 
and charging Excel’s color scheme.
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Changing the Look of Excel
With Excel 2013, what you see isn’t necessarily what you have to live with. This tip describes several 

ways to change the look of Excel. Some changes affect only the appearance. Other options allow you 

to hide various parts of Excel to make more room for displaying your data — or maybe because you 

prefer a less-cluttered look.

Cosmetic changes
When the preview version of Microsoft Office 2013 became available, there was a minor uproar 

about its appearance. Compared to previous versions, the applications looked “flat” and many com-

plained about the overall white color.

When the final version was released, Microsoft added two alternative Office themes: light gray and 

dark gray. To switch to a different theme, choose File➜Options to display the Excel Options dialog 

box. Click the General tab and use the Office Theme drop-down list (see Figure 1-1). The theme 

choice affects the appearance of the title bar, row and column borders, task panes, the taskbar, and a 

few other items. The theme you choose applies to all other Office 2013 applications.

Figure 1-1: Selecting a different Office theme.

Figure 1-1 shows another option: Office Background. Use this drop-down list to select a background 

image that appears in the Excel title bar. Fortunately, one of the options is No Background.
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Hiding the Ribbon
To hide the Ribbon, click the Ribbon Display Options drop-down menu in the Excel title bar. You’ll 

see the choices shown in Figure 1-2.

Figure 1-2: Choosing how the Ribbon works.

Using options on the View tab
The View tab, shown in Figure 1-3, has three groups of commands that determine what you see 

onscreen.

➤ Workbook Views group: These options control the overall view. Most of the time, you’ll use 

Normal view. Page Layout view is useful if you require precise control over how the pages 

are laid out. Page Break Preview also shows page breaks, but the display isn’t nearly as nice. 

The status bar has icons for each of these views. Custom Views enable you to create named 

views of worksheet settings (for example, a view in which certain columns are hidden).

➤ Show group: The four checkboxes in this group control the visibility of the Ruler (relevant 

only in Page Layout view), the Formula bar, worksheet gridlines, and row and column 

headings.

➤ Zoom group: These commands enable you to zoom the worksheet in or out. Another way to 

zoom is to use the Zoom slider on the status bar.

Figure 1-3: Controls on the View tab.
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Hiding other elements
To hide other elements, you must make a trip to the Advanced tab of the Excel Options dialog box 

(choose File➜Options). Figure 1-4 shows workbook display options and worksheet display options. 

These options are self-explanatory.

Figure 1-4: Display options on the Advanced tab of the Excel Options dialog box.

Hiding the status bar
You can also hide the status bar, at the bottom of the Excel window. Doing so, however, requires VBA 

code.

 1. Press Alt+F11 to display the Visual Basic Editor.

 2. Press Ctrl+G to display the Immediate window.

 3. Type this statement and press Enter:

Application.DisplayStatusBar = False

The status bar will be removed from all open workbook windows. To redisplay the status bar, repeat 

those instructions, but specify True in the statement.
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Customizing the Quick Access Toolbar
If you find that you continually need to switch Ribbon tabs because a frequently used command 

never seems to be on the Ribbon that’s displayed, this tip is for you. The Quick Access toolbar is 

always visible, regardless of which Ribbon tab is selected. After you customize the Quick Access tool-

bar, your frequently used commands will always be one click away.

Note  

The only situation in which the Quick Access toolbar is not visible is when the title bar is 

hidden (by choosing Auto-Hide the Ribbon from the Ribbon Display Options drop-down 

list in the title bar).

About the Quick Access toolbar
By default, the Quick Access toolbar is located on the left side of the Excel title bar, and it includes 

three tools:

➤ Save: Saves the active workbook.

➤ Undo: Reverses the effect of the last action.

➤ Redo: Reverses the effect of the last undo.

Commands on the Quick Access toolbar always appear as small icons, with no text. When you hover 

your mouse pointer over an icon, you see the name of the command and a brief description.

As far as I can tell, the number of icons that you can add to your Quick Access toolbar is limitless. But 

regardless of the number of icons, the Quick Access toolbar always displays a single line of icons. If 

the number of icons exceeds the Excel window width, it displays an additional icon at the end: More 

Controls. Click the More Controls icon, and the hidden Quick Access toolbar icons appear in a pop-up 

window.

Adding new commands to the Quick Access toolbar
You can add a new command to the Quick Access toolbar in three ways:

➤ Click the Quick Access toolbar drop-down control, which displays a down-pointing arrow 

and is located on the right side of the Quick Access toolbar (see Figure 2-1). The list contains 

several commonly used commands. Select a command from the list, and Excel adds it to your 

Quick Access toolbar.

➤ Right-click any control on the Ribbon and choose Add to Quick Access Toolbar. The control is 

added to your Quick Access toolbar, positioned after the last control.

➤ Use the Quick Access Toolbar tab of the Excel Options dialog box. A quick way to access this 

dialog box is to right-click any Quick Access toolbar or Ribbon control and choose Customize 

Quick Access Toolbar.
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Figure 2-1: The Quick Access toolbar drop-down menu is one way to add a new command to the Quick Access 
toolbar.

Figure 2-2 shows the Quick Access Toolbar tab of the Excel Options dialog box. The left side of the dia-

log box displays a list of Excel commands, and the right side shows the commands that are now on the 

Quick Access toolbar. Above the command list on the left is a drop-down control that lets you filter the 

list. Select an item from the drop-down list, and the list displays only the commands for that item.

Figure 2-2: Use the Quick Access Toolbar tab in the Excel Options dialog box to customize the Quick Access 
toolbar.
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Some of the items in the drop-down list are described here:

➤ Popular Commands: Displays commands that Excel users commonly use.

➤ Commands Not in the Ribbon: Displays a list of commands that you cannot access from the 

Ribbon.

➤ All Commands: Displays a complete list of Excel commands.

➤ Macros: Displays a list of all available macros.

➤ File Tab: Displays the commands available in the back stage window.

➤ Home Tab: Displays all commands that are available when the Home tab is active.

In addition, the drop-down list contains an item for every other tab.

Sometimes, you need to do some guessing to find a particular command. For example, if you want to 

add the command that displays the Excel Options dialog box, you can find it listed as Options, not 

Excel Options.

Note  

Some commands simply aren’t available. For example, I’d like the Quick Access toolbar 

to display the command to toggle the “dashed line” page break display on a worksheet. 

The only way to issue that command is to display the Advanced tab of the Excel Options 

dialog box and then scroll down until you find the Show Page Breaks checkbox. No com-

mand for doing so can be added to the Quick Access toolbar.

To add an item to your Quick Access toolbar, select it from the list on the left and click Add. If you add 

a macro to your Quick Access toolbar, you can click the Modify button to change the text and choose 

a different icon for the macro.

Notice the drop-down control above the list on the right. This lets you create a Quick Access toolbar 

that’s specific to a particular workbook, which is most useful when you add workbook-specific macro 

commands to the Quick Access toolbar. Most of the time, you’ll use the setting labeled For All 

Documents (Default).

The only time you ever need to use the Quick Access Toolbar tab of the Excel Options dialog box is 

when you want to add a command that’s not on the Ribbon or add a command that executes a 

macro. In all other situations, it’s much easier to locate the command on the Ribbon, right-click the 

command, and choose Add to Quick Access Toolbar.

Only you can decide which commands to put on your Quick Access toolbar. In general, if you find 

that you use a particular command frequently, it should probably be on your Quick Access toolbar.
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Performing other Quick Access toolbar actions
Here are some other things you can do with your Quick Access toolbar:

➤ Rearrange the Quick Access toolbar icons. If you want to change the order of your Quick 

Access toolbar icons, you can do so on the Customization tab of the Excel Options dialog 

box. Select the command and then use the up- and down-arrow buttons on the right to 

move the icon.

➤ Display the Quick Access toolbar below the ribbon. To change the position of the Quick 

Access toolbar, choose the down-pointing arrow control and select Show below the Ribbon.

➤ Remove Quick Access toolbar icons. The easiest way to remove an icon from your Quick 

Access toolbar is to right-click the icon and choose Remove from Quick Access Toolbar. You 

can also use the Quick Access Toolbar tab of the Excel Options dialog box. Just select the 

command in the list on the right and click the Remove button.

➤ Share your Quick Access toolbar. Use the Import/Export button to save a file that contains 

your Quick Access toolbar customization. You can then share this file with others. 

Unfortunately, this file also contains any Ribbon customizations that you might have made 

(see Tip 3). In other words, you can’t share your Quick Access toolbar without also sharing 

your Ribbon customizations.

➤ Reset the Quick Access toolbar. If you want to return the Quick Access toolbar to its default 

state, display the Quick Access Toolbar tab in the Excel Options dialog box and click the 

Reset button and choose Reset Only Quick Access Toolbar. All your customizations disap-

pear, and the Quick Access toolbar then displays its three default commands. 
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Customizing the Ribbon
Tip 2 describes how to customize the Quick Access toolbar by adding Ribbon commands, but some 

users prefer to make some changes to the Ribbon itself.

You can customize the Ribbon in these ways:

➤ Add a new tab.

➤ Add a new group to tab.

➤ Add commands to a group.

➤ Remove groups from a tab.

➤ Remove commands from custom groups.

➤ Change the order of the tabs.

➤ Change the order of the groups within a tab.

➤ Change the name of a tab.

➤ Change the name of a group.

➤ Reset the Ribbon to remove all customizations.

That’s a fairly comprehensive list of customization options, but you cannot do some actions:

➤ You cannot remove built-in tabs — but you can hide them.

➤ You cannot add commands to built-in groups.

➤ You cannot remove commands from built-in groups.

➤ You cannot change the order of commands in a built-in group.

Note  

Unfortunately, you can’t customize the Ribbon (or Quick Access toolbar) by using VBA 

macros. However, developers can write RibbonX code and store it in workbook files. 

When the file is open, the Ribbon is modified to display new commands. Writing 

RibbonX is relatively complicated and is the subject of several complete books.

How to customize the Ribbon
You customize the Ribbon in the Customize Ribbon tab of the Excel Options dialog box (see Figure 3-1). 

The quickest way to display this dialog box is to right-click anywhere in the Ribbon and choose 

Customize the Ribbon.
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Figure 3-1: The Customize Ribbon tab of the Excel Options dialog box.

Customizing the Ribbon is very similar to customizing the Quick Access toolbar, which is described in 

Tip 2. The only difference is that you need to decide where to put the command within the Ribbon. 

Here’s the general procedure:

 1. Right-click any part of the Ribbon, and choose Customize the Ribbon. Excel displays the 

Customize Ribbon tab of the Excel Options dialog box. 

 2. Use the drop-down list on the left (labeled Choose Command From) to display various 

groups of commands.

 3. Locate the command you want in the list box on the left and select it.

 4. Use the drop-down list on the right (labeled Customize the Ribbon) to choose a group of tabs.

  Main Tabs refers to the tabs that are always visible; Tool Tabs refers to the context tabs that 

appear when a particular object is selected.

 5. In the list box on the right, select the tab and the group where you want to put the command.

  You must click the “plus sign” controls to expand the hierarchical lists. Remember that you 

cannot add commands to built-in groups, so you may need to use the New Tab or New 

Group buttons to add a tab or group.

 6. Click the Add button to add the selected command from the left to the group on the right.

When you are finished making your Ribbon changes, click OK to close the Excel Options dialog box.
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New tabs and groups are given generic names, so you’ll probably want to give them more meaning-

ful names. Use the Rename button to rename the selected tab or group. You can also rename built-in 

tabs and groups.

Although you cannot remove a built-in tab, you can hide the tab by unchecking the check box next 

to its name.

Figure 3-2 shows a part of a customized Ribbon. In this case, I added a group to the View tab. The 

new Text To Speech group has five commands. I inserted this new group between the Zoom and the 

Window groups.

Figure 3-2: The View tab, with a new group added.


