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Introduction

n its broadest sense, a macro is a sequence of instructions that automates some

aspect of Excel so that you can work more efficiently and with fewer errors. You

might create a macro, for example, to format and print a month-end sales
report. After you develop the macro, you can execute it to perform many time-
consuming procedures automatically.

Macros are written in VBA, which stands for Visual Basic for Applications. VBA is
a programming language developed by Microsoft and a tool used to develop
programs that control Excel.

Excel programming terminology can be a bit confusing. For example, VBA is a
programming language but also serves as a macro language. What do you call
something written in VBA and executed in Excel? Is it a macro or is it a program?
Excel’s Help system often refers to VBA procedures as macros, so this is the
terminology used in this book.

You’ll also see the term automate throughout this book. This word means that a
series of steps are completed automatically. For example, if you write a macro that
adds color to some cells, prints the worksheet, and then removes the color, you
have automated those three steps.

You’re probably aware that people use Excel for thousands of different tasks. Here
are just a few examples:

¥ Keeping lists of things, such as customer names and transactions
¥ Budgeting and forecasting
¥ Analyzing scientific data

¥ Creating invoices and other forms

3 Developing charts from data

The list could go on and on. The point is simply that Excel is used for a wide
variety of tasks, and everyone reading this book has different needs and expecta-
tions regarding Excel. One thing most readers have in common, however, is the
need to automate some aspect of Excel, which is what macros (and this book)
are all about.
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About This Book

This book approaches the topic of Excel macros with the recognition that pro-
gramming VBA takes time and practice — time that you may not have right now.
In fact, many analysts don’t have the luxury of taking a few weeks to become
expert at VBA. So instead of the same general overview of VBA topics, this book
provides some of the most commonly used real-world Excel macros.

Each section in the book outlines a common problem and provides an Excel macro
to solve the problem — along with a detailed explanation of how the macro works
and where to use it.

Each section presents the following:

3 The problem
¥ The macro solution

3 How the macro works
After reading each section, you’ll be able to

¥ Immediately implement the required Excel macro
¥ Understand how the macro works

¥ Reuse the macro in other workbooks or with other macros

The macros in this book are designed to get you up and running with VBA in the
quickest way possible. Each macro tackles a common task that benefits from
automation. The idea here is to learn through application. This book is designed
so that you can implement the macro while getting a clear understanding of what
the macro does and how it works.

Foolish Assumptions

2

I make three assumptions about you as the reader:

¥ You've installed Microsoft Excel 2007 or a higher version.
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¥ You have some familiarity with the basic concepts of data analysis, such as
working with tables, aggregating data, creating formulas, referencing cells,
filtering, and sorting.

¥ You have an Internet connection so you can download the sample files, found
atwww.dummies.com/go/excelmacros.

Icons Used in This Book

@ Tip icons cover tricks or techniques related to the current discussion.

TIP

Remember icons indicate notes or asides that are important to keep in mind.

REMEMBER

& Warning icons hold critical information about pitfalls you will want to avoid.

WARNING

Beyond the Book

In addition to the material in the print or e-book you’re reading, this product
comes with more online goodies:

¥ Sampile files: Each macro in this book has an associated sample file that
enables you to see the macro working and to review the code. You can use
the sample files also to copy and paste the code into your environment (as
opposed to typing each macro from scratch). Download the sample files at:

www . dummies.com/go/excelmacros

Each macro in this book has detailed instructions on where to copy and paste
the code. In general terms, you open the sample file associated with the
macro, go to the Visual Basic Editor (by pressing Alt+F11), and copy the code.
Then you go to your workbook, open the Visual Basic Editor, and paste the
code in the appropriate location.
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REMEMBER

Q

TIP

Note that in some macros, you need to change the macro to suit your
situation. For example, in the macro that prints all workbooks in a directory
(see Chapter 4), you point to the C:\Temp\ directory. Before using this macro,
you must edit it to point to your target directory.

If a macro is not working for you, most likely a component of the macro needs
to be changed. Pay special attention to range addresses, directory names, and
any other hard-coded names.

¥ Cheat sheet: The cheat sheet offers shortcut keys that can help you work
more efficiently in Excel's Visual Basic Editor. You can find the cheat sheet by
visiting www . dummies . com and searching for “Excel Macros Cheat Sheet”.

Where to Go from Here

4

If you’re completely new to Excel macros, start with Part 1 (Chapters 1 - 3) to get
the fundamentals you’ll need to leverage the macros in this book. There, you will
gain a concise understanding of how macros and VBA work, along with the basic
foundation you need to implement the macros provided in this book.

If you’ve got some macro experience and want to dive right into the macro exam-
ples, feel free to peruse Chapters 4 — 9 and search for the task or macro that looks
interesting to you. Don’t worry. Each macro example stands on its own within its
own section that gives you all the guidance you need to understand and imple-
ment the code in your own workbook.

Visit Part 2 if you’re interested in macros that automate common workbook and
worksheet tasks to save time and gain efficiencies.

Explore Part 3 to find macros that navigate ranges, format cells, and manipulate
the data in your workbooks.

If you want to find macros that work with PivotTables, charts, and emails, thumb
through the macros in Part 4 where you will discover macros that automate
redundant PivotTable and chart tasks, as well as macros that send emails and
connect to external data sources.

Don’t forget to hit Part 5 for some useful tips and advice on how to get the most
out of your new macro skills.
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Here are some final things to keep in mind while working with the macros in this
book:

»

»

»

»

Any file that contains a macro must have the .xIsm file extension. See
the section on macro-enabled file extensions in Chapter 1 for more
information.

Excel does not run macros until they are enabled. As you implement these
macros, you and your customers must comply with Excel's macro security
measures. See the section in Chapter 1 on macro security in Excel for details.

You cannot undo macro actions. When working in Excel, you can often undo
the actions you've taken because Excel keeps a log (called the undo stack)
recording your last 100 actions. However, running a macro automatically
destroys the undo stack, so you can’t undo the actions you take in a macro.

You need to tweak the macros to fit your workbook. Many of the macros
reference example sheet names and ranges that you may not have in your
workbook. Be sure to replace references like “Sheet 1" or Range(“A1”) with the
sheet names and cell addresses you are working with in your own workbooks.
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IN THIS PART ...

Build a foundation for your macro skills with
fundamental macro recording concepts.

Get a solid understanding of the ground rules for using
and distributing macros in Excel.

Explore Excel's coding environment with a deep-dive of
the Visual Basic Editor.

Explore how to leverage the Excel object model to start
writing your own macros from scratch.

Understand the roles played by variables, events, and
error handling in macro development.



IN THIS CHAPTER

» Why use macros

» Recording macros
» Understanding macro security

» Examples of macros in action

Chapter 1
Macro Fundamentals

macro is essentially a set of instructions or code that you create to tell Excel
to execute any number of actions. In Excel, macros can be written or
recorded. The key word here is recorded.

Recording a macro is like programming a phone number into your cell phone. You
first manually dial and save a number. Then when you want, you can redial those
numbers with the touch of a button. Just as on a cell phone, you can record your
actions in Excel while you perform them. While you record, Excel gets busy in the
background, translating your keystrokes and mouse clicks to written code (also
known as Visual Basic for Applications (VBA)). After a macro is recorded, you can
play back those actions anytime you want.

In this chapter, you’ll explore macros and learn how you can use macros to auto-
mate your recurring processes to simplify your life.

Why Use a Macro?

The first step in using macros is admitting you have a problem. Actually, you may
have several problems:

3 Problem 1 - Repetitive tasks: As each new month rolls around, you have to
make the donuts (that is, crank out those reports). You have to import that data.
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You have to update those PivotTables. You have to delete those columns, and
so on. Wouldn't it be nice if you could fire up a macro and have those more
redundant parts of your dashboard processes done automatically?

Problem 2 - You're making mistakes: When you go hand-to-hand combat
with Excel, you're bound to make mistakes. When you're repeatedly applying
formulas, sorting, and moving things around manually, there’s always that risk
of catastrophe. Add to that the looming deadlines and constant change
requests, and your error rate goes up. Why not calmly record a macro, ensure
that everything is running correctly, and then forget it? The macro is sure to
perform every action the same way every time you run it, reducing the chance
of errors.

Problem 3 - Awkward navigation: You often create reports for an audience
that probably has a limited knowledge of Excel. It's always helpful to make
your reports more user-friendly. Macros can be used to dynamically format
and print worksheets, navigate to specific sheets in your workbook, or even
save the open document in a specified location. Your audience will appreciate
these little touches that help make perusal of your workbooks a bit more
pleasant.

Macro Recording Basics

10

To start recording your first macro, you need to first find the Macro Recorder,
which is on the Developer tab. Unfortunately, Excel comes out of the box with the
Developer tab hidden — you may not see it on your version of Excel at first. If you
plan to work with VBA macros, you’ll want to make sure that the Developer tab is
visible. To display this tab

1.
2.
3.
4.

Choose File > Excel Options.
In the Excel Options dialog box, select Customize Ribbon.
In the list box on the right, place a check mark next to Developer.

Click OK to return to Excel.

Now that you have the Developer tab showing in the Excel Ribbon, you can start
up the Macro Recorder by selecting Record Macro from the Developer tab. This
activates the Record Macro dialog box, as shown in Figure 1-1.
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FIGURE 1-1:
The Record
Macro dialog box.

Record Macro 2 =

Macro name:
Shortcut key:

Store macro in:
This Workbook [~]

Description:

Macrol

Ctrl=

QK ] | Cancel

Here are the four parts of the Record Macro dialog box:

»

»

»

»

Macro Name: This should be self-explanatory. Excel gives a default name to
your macro, such as Macro1, but you should give your macro a name more
descriptive of what it actually does. For example, you might name a macro
that formats a generic table as FormatTable.

Shortcut Key: Every macro needs an event, or something to happen, for it to
run. This event can be a button press, a workbook opening, or in this case, a
keystroke combination. When you assign a shortcut key to your macro,
entering that combination of keys triggers your macro to run. This is an
optional field.

Store Macro In: This Workbook is the default option. Storing your macro in
This Workbook simply means that the macro is stored along with the active
Excel file. The next time you open that particular workbook, the macro is
available to run. Similarly, if you send the workbook to another user, that user
can run the macro as well (provided the macro security is properly set by your
user — more on that later in this chapter).

Description: This is an optional field, but it can come in handy if you have
numerous macros in a spreadsheet or if you need to give a user a more
detailed description about what the macro does.

With the Record Macro dialog box open, follow these steps to create a simple
macro that enters your name into a worksheet cell:

1.

Enter a new single-word name for the macro to replace the default
Macro1 name.

A good name for this example is MyName.

CHAPTER 1 Macro Fundamentals
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2. Assign this macro to the shortcut key Ctrl+Shift+N.

You do this by entering uppercase N in the edit box labeled Shortcut Key.
3. Cclick OK.

This closes the Record Macro dialog box and begins recording your actions.

4. select any cell on your Excel spreadsheet, type your name into the
selected cell, and then press Enter.

5. choose Developer > Code > Stop Recording (or click the Stop Recording
button in the status bar).

Examining the macro

The macro was recorded in a new module named Module1. To view the code in this
module, you must activate the Visual Basic Editor. You can activate the VB Editor
in either of two ways:

¥ Press Alt+F11.

¥ Choose Developer > Code = Visual Basic.

In the VB Editor, the Project window displays a list of all open workbooks and add-
ins. This list is displayed as a tree diagram, which you can expand or collapse. The
code that you recorded previously is stored in Module1 in the current workbook.
When you double-click Module1, the code in the module appears in the Code
window.

The macro should look something like this:

Sub MyName ()

1

1

MyName Macro

' Keyboard Shortcut: Ctrl4Shift+N
ActiveCell.FormulaR1C1 = "Michael Alexander"

End Sub

The macro recorded is a Sub procedure named MyName. The statements tell Excel
what to do when the macro is executed.

Notice that Excel inserted some comments at the top of the procedure. These
comments are some of the information that appeared in the Record Macro dialog
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REMEMBER

box. These comment lines (which begin with an apostrophe) aren’t really neces-
sary, and deleting them has no effect on how the macro runs. If you ignore the
comments, you’ll see that this procedure has only one VBA statement:

ActiveCell.FormulaR1C1 = "Michael Alexander"

This single statement causes the name you typed while recording to be inserted
into the active cell.

Testing the macro

Before you recorded this macro, you set an option that assigned the macro to the
Ctrl+Shift+N shortcut key combination. To test the macro, return to Excel by using
either of the following methods:

¥ Press Alt+F11.

3 Click the View Microsoft Excel button on the VB Editor toolbar.

When Excel is active, activate a worksheet. (It can be in the workbook that con-
tains the VBA module or in any other workbook.) Select a cell and press
Ctrl+Shift+N. The macro immediately enters your name into the cell.

In the preceding example, notice that you selected the cell to be altered before you
started recording your macro. This step is important. If you select a cell while the
macro recorder is turned on, the actual cell that you selected is recorded into the
macro. In such a case, the macro would always format that particular cell, and it
would not be a general-purpose macro.

Editing the macro

After you record a macro, you can make changes to it (although you must know

what you’re doing). For example, assume that you want your name to be bold. You

could re-record the macro, but this modification is simple, so editing the code is

more efficient. Press Alt+F11 to activate the VB Editor window. Then activate Mod-

ule1 and insert the following statement before the End Sub statement:
ActiveCell.Font.Bold = True

The edited macro appears as follows:

Sub MyName( )
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' MyName Macro

' Keyboard Shortcut: Ctrl+Shift+N
ActiveCell.Font.Bold = True
ActiveCell.FormulaR1C1 = "Michael Alexander"

End Sub

Test this new macro, and you see that it performs as it should.

Comparing Absolute and Relative
Macro Recording

Now that you’ve read about the basics of the Macro Recorder interface, it’s time to
go deeper and begin recording macros. The first thing you need to understand
before you begin is that Excel has two modes for recording — absolute reference
and relative reference.

Recording macros with absolute references

Excel’s default recording mode is in absolute reference. As you may know, the
term absolute reference is often used in the context of cell references found in
formulas. When a cell reference in a formula is an absolute reference, it does not
automatically adjust when the formula is pasted to a new location.

The best way to understand how this concept applies to macros is to try it out.
Open the Chapter 1 Sample File.xlsx file and record a macro that counts the rows
in the Branchlist worksheet. (See Figure 1-2.)

The sample dataset used in this chapter can be found on this book’s companion
website at www . dummies . com/go/excelmacros

TIP
Follow these steps to record the macro:

1. Before recording, make sure cell A1 is selected.
2. select Record Macro from the Developer tab.
3. Name the macro AddTotal.

4. Choose This Workbook for the save location.
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